Nacionalni CERT

Sigurnosni nedostaci programskog paketa tiff

<p>SUSE Security Update: Security update for tiff<br />______________________________________________________________________________<br /><br />Announcement ID: SUSE-SU-2018:0073-1<br />Rating: important<br />References: #1017690 #1069213 #960341 #969783 #983436 <br /> <br />Cross-References: CVE-2014-8128 CVE-2015-7554 CVE-2016-10095<br /> CVE-2016-5318 CVE-2017-16232<br />Affected Products:<br /> SUSE Linux Enterprise Software Development Kit 12-SP3<br /> SUSE Linux Enterprise Software Development Kit 12-SP2<br /> SUSE Linux Enterprise Server for Raspberry Pi 12-SP2<br /> SUSE Linux Enterprise Server 12-SP3<br /> SUSE Linux Enterprise Server 12-SP2<br /> SUSE Linux Enterprise Desktop 12-SP3<br /> SUSE Linux Enterprise Desktop 12-SP2<br />______________________________________________________________________________<br /><br /> An update that fixes 5 vulnerabilities is now available.<br /><br />Description:<br /><br /> This update for tiff to version 4.0.9 fixes the following issues:<br /><br /> Security issues fixed:<br /><br /> - CVE-2014-8128: Fix out-of-bounds read with malformed TIFF image in<br /> multiple tools (bsc#969783).<br /> - CVE-2015-7554: Fix invalid write in tiffsplit / _TIFFVGetField<br /> (bsc#960341).<br /> - CVE-2016-10095: Fix stack-based buffer overflow in _TIFFVGetField<br /> (tif_dir.c) (bsc#1017690).<br /> - CVE-2016-5318: Fix stackoverflow in thumbnail (bsc#983436).<br /> - CVE-2017-16232: Fix memory-based DoS in tiff2bw (bsc#1069213).<br /><br /><br />Patch Instructions:<br /><br /> To install this SUSE Security Update use YaST online_update.<br /> Alternatively you can run the command listed for your product:<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP3:<br /><br /> zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-59=1<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-SDK-12-SP2-2018-59=1<br /><br /> - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-RPI-12-SP2-2018-59=1<br /><br /> - SUSE Linux Enterprise Server 12-SP3:<br /><br /> zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-59=1<br /><br /> - SUSE Linux Enterprise Server 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-59=1<br /><br /> - SUSE Linux Enterprise Desktop 12-SP3:<br /><br /> zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-59=1<br /><br /> - SUSE Linux Enterprise Desktop 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2018-59=1<br /><br /> To bring your system up-to-date, use "zypper patch".<br /><br /><br />Package List:<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):<br /><br /> libtiff-devel-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le s390x x86_64):<br /><br /> libtiff-devel-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):<br /><br /> libtiff5-4.0.9-44.7.1<br /> libtiff5-debuginfo-4.0.9-44.7.1<br /> tiff-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):<br /><br /> libtiff5-4.0.9-44.7.1<br /> libtiff5-debuginfo-4.0.9-44.7.1<br /> tiff-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Server 12-SP3 (s390x x86_64):<br /><br /> libtiff5-32bit-4.0.9-44.7.1<br /> libtiff5-debuginfo-32bit-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le s390x x86_64):<br /><br /> libtiff5-4.0.9-44.7.1<br /> libtiff5-debuginfo-4.0.9-44.7.1<br /> tiff-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Server 12-SP2 (s390x x86_64):<br /><br /> libtiff5-32bit-4.0.9-44.7.1<br /> libtiff5-debuginfo-32bit-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Desktop 12-SP3 (x86_64):<br /><br /> libtiff5-32bit-4.0.9-44.7.1<br /> libtiff5-4.0.9-44.7.1<br /> libtiff5-debuginfo-32bit-4.0.9-44.7.1<br /> libtiff5-debuginfo-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /> - SUSE Linux Enterprise Desktop 12-SP2 (x86_64):<br /><br /> libtiff5-32bit-4.0.9-44.7.1<br /> libtiff5-4.0.9-44.7.1<br /> libtiff5-debuginfo-32bit-4.0.9-44.7.1<br /> libtiff5-debuginfo-4.0.9-44.7.1<br /> tiff-debuginfo-4.0.9-44.7.1<br /> tiff-debugsource-4.0.9-44.7.1<br /><br /><br />References:<br /><br /> https://www.suse.com/security/cve/CVE-2014-8128.html<br /> https://www.suse.com/security/cve/CVE-2015-7554.html<br /> https://www.suse.com/security/cve/CVE-2016-10095.html<br /> https://www.suse.com/security/cve/CVE-2016-5318.html<br /> https://www.suse.com/security/cve/CVE-2017-16232.html<br /> https://bugzilla.suse.com/1017690<br /> https://bugzilla.suse.com/1069213<br /> https://bugzilla.suse.com/960341<br /> https://bugzilla.suse.com/969783<br /> https://bugzilla.suse.com/983436<br /><br />-- <br />To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org<br />For additional commands, e-mail: opensuse-security-announce+help@opensuse.org</p>
Otkriveni su sigurnosni nedostaci u programskom paketu tiff za operacijski sustav SUSE. Otkriveni nedostaci potencijalnim napadačima omogućuju izazivanje DoS stanja ili druge nespecificirane vrste napada. Savjetuje se ažuriranje izdanim zakrpama.