Nacionalni CERT

Sigurnosni nedostaci programske biblioteke glibc

<p>SUSE Security Update: Security update for glibc<br />______________________________________________________________________________<br /><br />Announcement ID: SUSE-SU-2018:0074-1<br />Rating: important<br />References: #1051042 #1053188 #1063675 #1064569 #1064580 <br /> #1064583 #1070905 #1071319 #1073231 #1074293 <br /> <br />Cross-References: CVE-2017-1000408 CVE-2017-1000409 CVE-2017-15670<br /> CVE-2017-15671 CVE-2017-15804 CVE-2017-16997<br /> CVE-2018-1000001<br />Affected Products:<br /> SUSE Linux Enterprise Software Development Kit 12-SP3<br /> SUSE Linux Enterprise Software Development Kit 12-SP2<br /> SUSE Linux Enterprise Server for Raspberry Pi 12-SP2<br /> SUSE Linux Enterprise Server 12-SP3<br /> SUSE Linux Enterprise Server 12-SP2<br /> SUSE Linux Enterprise Desktop 12-SP3<br /> SUSE Linux Enterprise Desktop 12-SP2<br /> SUSE CaaS Platform ALL<br /> OpenStack Cloud Magnum Orchestration 7<br />______________________________________________________________________________<br /><br /> An update that solves 7 vulnerabilities and has three fixes<br /> is now available.<br /><br />Description:<br /><br /> This update for glibc fixes the following issues:<br /><br /> - A privilege escalation bug in the realpath() function has been fixed.<br /> [CVE-2018-1000001, bsc#1074293]<br /><br /> - A memory leak and a buffer overflow in the dynamic ELF loader has been<br /> fixed. [CVE-2017-1000408, CVE-2017-1000409, bsc#1071319]<br /><br /> - An issue in the code handling RPATHs was fixed that could have been<br /> exploited by an attacker to execute code loaded from arbitrary<br /> libraries. [CVE-2017-16997, bsc#1073231]<br /><br /> - A potential crash caused by a use-after-free bug in pthread_create() has<br /> been fixed. [bsc#1053188]<br /><br /> - A bug that prevented users to build shared objects which use the<br /> optimized libmvec.so API has been fixed. [bsc#1070905]<br /><br /> - A memory leak in the glob() function has been fixed. [CVE-2017-15670,<br /> CVE-2017-15671, CVE-2017-15804, bsc#1064569, bsc#1064580, bsc#1064583]<br /><br /> - A bug that would lose the syscall error code value in case of crashes<br /> has been fixed. [bsc#1063675]<br /><br /><br />Patch Instructions:<br /><br /> To install this SUSE Security Update use YaST online_update.<br /> Alternatively you can run the command listed for your product:<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP3:<br /><br /> zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-55=1<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-SDK-12-SP2-2018-55=1<br /><br /> - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-RPI-12-SP2-2018-55=1<br /><br /> - SUSE Linux Enterprise Server 12-SP3:<br /><br /> zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-55=1<br /><br /> - SUSE Linux Enterprise Server 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-55=1<br /><br /> - SUSE Linux Enterprise Desktop 12-SP3:<br /><br /> zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-55=1<br /><br /> - SUSE Linux Enterprise Desktop 12-SP2:<br /><br /> zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2018-55=1<br /><br /> - SUSE CaaS Platform ALL:<br /><br /> zypper in -t patch SUSE-CAASP-ALL-2018-55=1<br /><br /> - OpenStack Cloud Magnum Orchestration 7:<br /><br /> zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-55=1<br /><br /> To bring your system up-to-date, use "zypper patch".<br /><br /><br />Package List:<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):<br /><br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-static-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP3 (noarch):<br /><br /> glibc-info-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le s390x x86_64):<br /><br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-static-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Software Development Kit 12-SP2 (noarch):<br /><br /> glibc-info-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-2.22-62.3.4<br /> glibc-devel-debuginfo-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /> glibc-profile-2.22-62.3.4<br /> nscd-2.22-62.3.4<br /> nscd-debuginfo-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (noarch):<br /><br /> glibc-html-2.22-62.3.4<br /> glibc-i18ndata-2.22-62.3.4<br /> glibc-info-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-2.22-62.3.4<br /> glibc-devel-debuginfo-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /> glibc-profile-2.22-62.3.4<br /> nscd-2.22-62.3.4<br /> nscd-debuginfo-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server 12-SP3 (s390x x86_64):<br /><br /> glibc-32bit-2.22-62.3.4<br /> glibc-debuginfo-32bit-2.22-62.3.4<br /> glibc-devel-32bit-2.22-62.3.4<br /> glibc-devel-debuginfo-32bit-2.22-62.3.4<br /> glibc-locale-32bit-2.22-62.3.4<br /> glibc-locale-debuginfo-32bit-2.22-62.3.4<br /> glibc-profile-32bit-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server 12-SP3 (noarch):<br /><br /> glibc-html-2.22-62.3.4<br /> glibc-i18ndata-2.22-62.3.4<br /> glibc-info-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le s390x x86_64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-2.22-62.3.4<br /> glibc-devel-debuginfo-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /> glibc-profile-2.22-62.3.4<br /> nscd-2.22-62.3.4<br /> nscd-debuginfo-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server 12-SP2 (s390x x86_64):<br /><br /> glibc-32bit-2.22-62.3.4<br /> glibc-debuginfo-32bit-2.22-62.3.4<br /> glibc-devel-32bit-2.22-62.3.4<br /> glibc-devel-debuginfo-32bit-2.22-62.3.4<br /> glibc-locale-32bit-2.22-62.3.4<br /> glibc-locale-debuginfo-32bit-2.22-62.3.4<br /> glibc-profile-32bit-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Server 12-SP2 (noarch):<br /><br /> glibc-html-2.22-62.3.4<br /> glibc-i18ndata-2.22-62.3.4<br /> glibc-info-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Desktop 12-SP3 (x86_64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-32bit-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debuginfo-32bit-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-2.22-62.3.4<br /> glibc-devel-32bit-2.22-62.3.4<br /> glibc-devel-debuginfo-2.22-62.3.4<br /> glibc-devel-debuginfo-32bit-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-32bit-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /> glibc-locale-debuginfo-32bit-2.22-62.3.4<br /> nscd-2.22-62.3.4<br /> nscd-debuginfo-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Desktop 12-SP3 (noarch):<br /><br /> glibc-i18ndata-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Desktop 12-SP2 (noarch):<br /><br /> glibc-i18ndata-2.22-62.3.4<br /><br /> - SUSE Linux Enterprise Desktop 12-SP2 (x86_64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-32bit-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debuginfo-32bit-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-devel-2.22-62.3.4<br /> glibc-devel-32bit-2.22-62.3.4<br /> glibc-devel-debuginfo-2.22-62.3.4<br /> glibc-devel-debuginfo-32bit-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-32bit-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /> glibc-locale-debuginfo-32bit-2.22-62.3.4<br /> nscd-2.22-62.3.4<br /> nscd-debuginfo-2.22-62.3.4<br /><br /> - SUSE CaaS Platform ALL (x86_64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /><br /> - OpenStack Cloud Magnum Orchestration 7 (x86_64):<br /><br /> glibc-2.22-62.3.4<br /> glibc-debuginfo-2.22-62.3.4<br /> glibc-debugsource-2.22-62.3.4<br /> glibc-locale-2.22-62.3.4<br /> glibc-locale-debuginfo-2.22-62.3.4<br /><br /><br />References:<br /><br /> https://www.suse.com/security/cve/CVE-2017-1000408.html<br /> https://www.suse.com/security/cve/CVE-2017-1000409.html<br /> https://www.suse.com/security/cve/CVE-2017-15670.html<br /> https://www.suse.com/security/cve/CVE-2017-15671.html<br /> https://www.suse.com/security/cve/CVE-2017-15804.html<br /> https://www.suse.com/security/cve/CVE-2017-16997.html<br /> https://www.suse.com/security/cve/CVE-2018-1000001.html<br /> https://bugzilla.suse.com/1051042<br /> https://bugzilla.suse.com/1053188<br /> https://bugzilla.suse.com/1063675<br /> https://bugzilla.suse.com/1064569<br /> https://bugzilla.suse.com/1064580<br /> https://bugzilla.suse.com/1064583<br /> https://bugzilla.suse.com/1070905<br /> https://bugzilla.suse.com/1071319<br /> https://bugzilla.suse.com/1073231<br /> https://bugzilla.suse.com/1074293<br /><br />-- <br />To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org<br />For additional commands, e-mail: opensuse-security-announce+help@opensuse.org</p>
Otkriveni su sigurnosni nedostaci u programskoj biblioteci glibc za operacijski sustav SUSE. Otkriveni nedostaci potencijalnim napadačima omogućuju stjecanje povišenih ovlasti, izvođenje napada uskraćivanjem usluge ili izvršavanje proizvoljnog programskog koda. Savjetuje se ažuriranje izdanim zakrpama.