Nacionalni CERT

Sigurnosni nedostaci programskog paketa xen

<p>openSUSE Security Update: Security update for xen<br />______________________________________________________________________________<br /><br />Announcement ID: openSUSE-SU-2017:1078-1<br />Rating: important<br />References: #1014136 #1015348 #1022555 #1026236 #1027519 <br /> #1028235 #1029128 #1029827 #1030144 #1030442 <br /> <br />Cross-References: CVE-2017-6505 CVE-2017-7228<br />Affected Products:<br /> openSUSE Leap 42.2<br />______________________________________________________________________________<br /><br /> An update that solves two vulnerabilities and has 8 fixes<br /> is now available.<br /><br />Description:<br /><br /><br /> This update for xen to version 4.7.2 fixes the following issues:<br /><br /> These security issues were fixed:<br /><br /> - CVE-2017-7228: Broken check in memory_exchange() permited PV guest<br /> breakout (bsc#1030442).<br /> - XSA-206: Unprivileged guests issuing writes to xenstore were able to<br /> stall progress of the control domain or driver domain, possibly leading<br /> to a Denial of Service (DoS) of the entire host (bsc#1030144).<br /> - CVE-2017-6505: The ohci_service_ed_list function in hw/usb/hcd-ohci.c<br /> allowed local guest OS users to cause a denial of service (infinite<br /> loop) via vectors involving the number of link endpoint list descriptors<br /> (bsc#1028235).<br /><br /> These non-security issues were fixed:<br /><br /> - bsc#1015348: libvirtd didn't not start during boot<br /> - bsc#1014136: kdump couldn't dump a kernel on SLES12-SP2 with Xen<br /> hypervisor.<br /> - bsc#1026236: Fixed paravirtualized performance<br /> - bsc#1022555: Timeout in "execution of /etc/xen/scripts/block add"<br /> - bsc#1029827: Forward port xenstored<br /> - bsc#1029128: Make xen to really produce xen.efi with gcc48<br /><br /> This update was imported from the SUSE:SLE-12-SP2:Update update project.<br /><br /><br />Patch Instructions:<br /><br /> To install this openSUSE Security Update use YaST online_update.<br /> Alternatively you can run the command listed for your product:<br /><br /> - openSUSE Leap 42.2:<br /><br /> zypper in -t patch openSUSE-2017-492=1<br /><br /> To bring your system up-to-date, use "zypper patch".<br /><br /><br />Package List:<br /><br /> - openSUSE Leap 42.2 (i586 x86_64):<br /><br /> xen-debugsource-4.7.2_02-11.3.1<br /> xen-devel-4.7.2_02-11.3.1<br /> xen-libs-4.7.2_02-11.3.1<br /> xen-libs-debuginfo-4.7.2_02-11.3.1<br /> xen-tools-domU-4.7.2_02-11.3.1<br /> xen-tools-domU-debuginfo-4.7.2_02-11.3.1<br /><br /> - openSUSE Leap 42.2 (x86_64):<br /><br /> xen-4.7.2_02-11.3.1<br /> xen-doc-html-4.7.2_02-11.3.1<br /> xen-libs-32bit-4.7.2_02-11.3.1<br /> xen-libs-debuginfo-32bit-4.7.2_02-11.3.1<br /> xen-tools-4.7.2_02-11.3.1<br /> xen-tools-debuginfo-4.7.2_02-11.3.1<br /><br /><br />References:<br /><br /> https://www.suse.com/security/cve/CVE-2017-6505.html<br /> https://www.suse.com/security/cve/CVE-2017-7228.html<br /> https://bugzilla.suse.com/1014136<br /> https://bugzilla.suse.com/1015348<br /> https://bugzilla.suse.com/1022555<br /> https://bugzilla.suse.com/1026236<br /> https://bugzilla.suse.com/1027519<br /> https://bugzilla.suse.com/1028235<br /> https://bugzilla.suse.com/1029128<br /> https://bugzilla.suse.com/1029827<br /> https://bugzilla.suse.com/1030144<br /> https://bugzilla.suse.com/1030442<br /><br />-- <br />To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org<br />For additional commands, e-mail: opensuse-security-announce+help@opensuse.org</p>
Otkriveni su sigurnosni nedostaci u programskom paketu xen za operacijski sustav openSUSE. Otkriveni nedostaci potencijalnim napadačima omogućuju izvođenje napada uskraćivanja usluge. Savjetuje se ažuriranje izdanim zakrpama.