Nacionalni CERT

Sigurnosni nedostaci programskog paketa xen

<p>SUSE Security Update: Security update for xen<br />______________________________________________________________________________<br /><br />Announcement ID: SUSE-SU-2017:0718-1<br />Rating: important<br />References: #1002496 #1012651 #1013657 #1013668 #1014298 <br /> #1014507 #1015169 #1016340 #1022871 #1023004 <br /> #1024183 #1024834 #907805 <br />Cross-References: CVE-2014-8106 CVE-2016-10013 CVE-2016-10024<br /> CVE-2016-10155 CVE-2016-9101 CVE-2016-9776<br /> CVE-2016-9911 CVE-2016-9921 CVE-2016-9922<br /> CVE-2016-9932 CVE-2017-2615 CVE-2017-2620<br /> <br />Affected Products:<br /> SUSE OpenStack Cloud 5<br /> SUSE Manager Proxy 2.1<br /> SUSE Manager 2.1<br /> SUSE Linux Enterprise Server 11-SP3-LTSS<br /> SUSE Linux Enterprise Point of Sale 11-SP3<br /> SUSE Linux Enterprise Debuginfo 11-SP3<br />______________________________________________________________________________<br /><br /> An update that solves 12 vulnerabilities and has one errata<br /> is now available.<br /><br />Description:<br /><br /><br /> This update for xen fixes several issues.<br /><br /> These security issues were fixed:<br /><br /> - CVE-2016-10155: The virtual hardware watchdog 'wdt_i6300esb' was<br /> vulnerable to a memory leakage issue allowing a privileged user to cause<br /> a DoS and/or potentially crash the Qemu process on the host (bsc#1024183)<br /> - CVE-2017-2620: In CIRRUS_BLTMODE_MEMSYSSRC mode the bitblit copy routine<br /> cirrus_bitblt_cputovideo failed to check the memory region, allowing for<br /> an out-of-bounds write that allows for privilege escalation (bsc#1024834)<br /> - CVE-2017-2615: An error in the bitblt copy operation could have allowed<br /> a malicious guest administrator to cause an out of bounds memory access,<br /> possibly leading to information disclosure or privilege escalation<br /> (bsc#1023004)<br /> - CVE-2014-8106: A heap-based buffer overflow in the Cirrus VGA emulator<br /> allowed local guest users to execute arbitrary code via vectors related<br /> to blit regions (bsc#907805)<br /> - CVE-2016-9911: The USB EHCI Emulation support was vulnerable to a memory<br /> leakage issue while processing packet data in 'ehci_init_transfer'. A<br /> guest user/process could have used this issue to leak host memory,<br /> resulting in DoS for the host (bsc#1014507)<br /> - CVE-2016-9921: The Cirrus CLGD 54xx VGA Emulator support was vulnerable<br /> to a divide by zero issue while copying VGA data. A privileged user<br /> inside guest could have used this flaw to crash the process instance on<br /> the host, resulting in DoS (bsc#1015169)<br /> - CVE-2016-9922: The Cirrus CLGD 54xx VGA Emulator support was vulnerable<br /> to a divide by zero issue while copying VGA data. A privileged user<br /> inside guest could have used this flaw to crash the process instance on<br /> the host, resulting in DoS (bsc#1015169)<br /> - CVE-2016-10013: Xen allowed local 64-bit x86 HVM guest OS users to gain<br /> privileges by leveraging mishandling of SYSCALL singlestep during<br /> emulation (bsc#1016340).<br /> - CVE-2016-9932: CMPXCHG8B emulation on x86 systems allowed local HVM<br /> guest OS users to obtain sensitive information from host stack memory<br /> via a "supposedly-ignored" operand size prefix (bsc#1012651).<br /> - CVE-2016-9101: A memory leak in hw/net/eepro100.c allowed local guest OS<br /> administrators to cause a denial of service (memory consumption and QEMU<br /> process crash) by repeatedly unplugging an i8255x (PRO100) NIC device<br /> (bsc#1013668)<br /> - CVE-2016-9776: The ColdFire Fast Ethernet Controller emulator support<br /> was vulnerable to an infinite loop issue while receiving packets in<br /> 'mcf_fec_receive'. A privileged user/process inside guest could have<br /> used this issue to crash the Qemu process on the host leading to DoS<br /> (bsc#1013657)<br /> - A malicious guest could have, by frequently rebooting over extended<br /> periods of time, run the host system out of memory, resulting in a<br /> Denial of Service (DoS) (bsc#1022871)<br /> - CVE-2016-10024: Xen allowed local x86 PV guest OS kernel administrators<br /> to cause a denial of service (host hang or crash) by modifying the<br /> instruction stream asynchronously while performing certain kernel<br /> operations (bsc#1014298)<br /><br /> This non-security issue was fixed:<br /><br /> - bsc#1002496: Added support for reloading clvm in block-dmmd block-dmmd<br /><br /><br />Patch Instructions:<br /><br /> To install this SUSE Security Update use YaST online_update.<br /> Alternatively you can run the command listed for your product:<br /><br /> - SUSE OpenStack Cloud 5:<br /><br /> zypper in -t patch sleclo50sp3-xen-13030=1<br /><br /> - SUSE Manager Proxy 2.1:<br /><br /> zypper in -t patch slemap21-xen-13030=1<br /><br /> - SUSE Manager 2.1:<br /><br /> zypper in -t patch sleman21-xen-13030=1<br /><br /> - SUSE Linux Enterprise Server 11-SP3-LTSS:<br /><br /> zypper in -t patch slessp3-xen-13030=1<br /><br /> - SUSE Linux Enterprise Point of Sale 11-SP3:<br /><br /> zypper in -t patch sleposp3-xen-13030=1<br /><br /> - SUSE Linux Enterprise Debuginfo 11-SP3:<br /><br /> zypper in -t patch dbgsp3-xen-13030=1<br /><br /> To bring your system up-to-date, use "zypper patch".<br /><br /><br />Package List:<br /><br /> - SUSE OpenStack Cloud 5 (x86_64):<br /><br /> xen-4.2.5_21-35.1<br /> xen-doc-html-4.2.5_21-35.1<br /> xen-doc-pdf-4.2.5_21-35.1<br /> xen-kmp-default-4.2.5_21_3.0.101_0.47.96-35.1<br /> xen-libs-32bit-4.2.5_21-35.1<br /> xen-libs-4.2.5_21-35.1<br /> xen-tools-4.2.5_21-35.1<br /> xen-tools-domU-4.2.5_21-35.1<br /><br /> - SUSE Manager Proxy 2.1 (x86_64):<br /><br /> xen-4.2.5_21-35.1<br /> xen-doc-html-4.2.5_21-35.1<br /> xen-doc-pdf-4.2.5_21-35.1<br /> xen-kmp-default-4.2.5_21_3.0.101_0.47.96-35.1<br /> xen-libs-32bit-4.2.5_21-35.1<br /> xen-libs-4.2.5_21-35.1<br /> xen-tools-4.2.5_21-35.1<br /> xen-tools-domU-4.2.5_21-35.1<br /><br /> - SUSE Manager 2.1 (x86_64):<br /><br /> xen-4.2.5_21-35.1<br /> xen-doc-html-4.2.5_21-35.1<br /> xen-doc-pdf-4.2.5_21-35.1<br /> xen-kmp-default-4.2.5_21_3.0.101_0.47.96-35.1<br /> xen-libs-32bit-4.2.5_21-35.1<br /> xen-libs-4.2.5_21-35.1<br /> xen-tools-4.2.5_21-35.1<br /> xen-tools-domU-4.2.5_21-35.1<br /><br /> - SUSE Linux Enterprise Server 11-SP3-LTSS (i586 x86_64):<br /><br /> xen-kmp-default-4.2.5_21_3.0.101_0.47.96-35.1<br /> xen-libs-4.2.5_21-35.1<br /> xen-tools-domU-4.2.5_21-35.1<br /><br /> - SUSE Linux Enterprise Server 11-SP3-LTSS (x86_64):<br /><br /> xen-4.2.5_21-35.1<br /> xen-doc-html-4.2.5_21-35.1<br /> xen-doc-pdf-4.2.5_21-35.1<br /> xen-libs-32bit-4.2.5_21-35.1<br /> xen-tools-4.2.5_21-35.1<br /><br /> - SUSE Linux Enterprise Server 11-SP3-LTSS (i586):<br /><br /> xen-kmp-pae-4.2.5_21_3.0.101_0.47.96-35.1<br /><br /> - SUSE Linux Enterprise Point of Sale 11-SP3 (i586):<br /><br /> xen-kmp-default-4.2.5_21_3.0.101_0.47.96-35.1<br /> xen-kmp-pae-4.2.5_21_3.0.101_0.47.96-35.1<br /> xen-libs-4.2.5_21-35.1<br /> xen-tools-domU-4.2.5_21-35.1<br /><br /> - SUSE Linux Enterprise Debuginfo 11-SP3 (i586 x86_64):<br /><br /> xen-debuginfo-4.2.5_21-35.1<br /> xen-debugsource-4.2.5_21-35.1<br /><br /><br />References:<br /><br /> https://www.suse.com/security/cve/CVE-2014-8106.html<br /> https://www.suse.com/security/cve/CVE-2016-10013.html<br /> https://www.suse.com/security/cve/CVE-2016-10024.html<br /> https://www.suse.com/security/cve/CVE-2016-10155.html<br /> https://www.suse.com/security/cve/CVE-2016-9101.html<br /> https://www.suse.com/security/cve/CVE-2016-9776.html<br /> https://www.suse.com/security/cve/CVE-2016-9911.html<br /> https://www.suse.com/security/cve/CVE-2016-9921.html<br /> https://www.suse.com/security/cve/CVE-2016-9922.html<br /> https://www.suse.com/security/cve/CVE-2016-9932.html<br /> https://www.suse.com/security/cve/CVE-2017-2615.html<br /> https://www.suse.com/security/cve/CVE-2017-2620.html<br /> https://bugzilla.suse.com/1002496<br /> https://bugzilla.suse.com/1012651<br /> https://bugzilla.suse.com/1013657<br /> https://bugzilla.suse.com/1013668<br /> https://bugzilla.suse.com/1014298<br /> https://bugzilla.suse.com/1014507<br /> https://bugzilla.suse.com/1015169<br /> https://bugzilla.suse.com/1016340<br /> https://bugzilla.suse.com/1022871<br /> https://bugzilla.suse.com/1023004<br /> https://bugzilla.suse.com/1024183<br /> https://bugzilla.suse.com/1024834<br /> https://bugzilla.suse.com/907805<br /><br />-- <br />To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org<br />For additional commands, e-mail: opensuse-security-announce+help@opensuse.org</p>
Otkriveni su sigurnosni nedostaci u programskom paketu xen za operacijski sustav SUSE. Otkriveni nedostaci potencijalnim napadačima omogućuju izazivanje DoS stanja, stjecanje uvećanih ovlasti, otkrivanje osjetljivih informacija ili izvršavanje proizvoljnog programskog koda. Savjetuje se ažuriranje izdanim zakrpama.